MxToolbox has resolved their issue, therefore we will resolve this issue here.
Posted Mar 28, 2025 - 14:50 CET
Monitoring
The underlying issue has been identified as being caused by our SPF check towards external partner MxToolbox failing.
MxToolbox has acknowledged the issue but cannot provide a timeline for solving it on their end. Therefore we have decided to make a temporary change on our side to ignore the error message MxToolbox is sending in the SPF check response. See this link to our Release Notes forum for more info on this change (in comments section) -> https://helpcenter.nshift.com/hc/en-us/articles/18852481268124-MyTranssmart-API-Release-notes-week-11-2025
Important note: this means we cannot always check if a correct SPF record is configured so please be sure that this step is performed properly when adding/changing the 'From email' field in a mail template.
We will update you here when the permanent fix is done.
Posted Mar 10, 2025 - 11:43 CET
Investigating
We've noticed that our mail enginge cannot check your SPF records properly anymore. Whenever you make a change to your mail config, specifically to your email addresses in From/BCC address parameters, you run the risk of this error popping up:
No SPF record is found for this emailadress, the emails won't be sent
For the time being therefore we advise you to not change any mail config until this is solved. When we have solved this, we will post a comment here.
If you want to keep yourself updated about this incident, please subscribe to this post.