IMG to ZPL logic causes corrupted or invalid labels

Incident Report for nShift - Transsmart

Resolved

The issue has been fixed and the labels of the shipments made in the down period work properly again
Posted Nov 13, 2025 - 14:32 CET

Update

The issue has been fixed which means that shipments made onwards will work properly, but shipments that have been affected by this in the last hour are still having corrupted labels, a solution for this is being investigated
Posted Nov 13, 2025 - 11:59 CET

Investigating

The logic we use to switch IMG to ZPL is affecting both production and accept environment, this is currently under investigation as a top priority
Posted Nov 13, 2025 - 11:42 CET
This incident affected: MyTranssmart dashboard, REST API, and SOAP webservice.