Carriercode DPA intermittently unavailable for booking
Incident Report for nShift - Transsmart
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 11:57 CET
Monitoring
DPD has fixed their issue around 20.47h last night, we are monitoring whether this fix solves the problem consistently this morning.
Posted Feb 22, 2024 - 08:49 CET
Investigating
Since this afternoon around 14.50h the connection with DPA is down intermittently. These are the errors you can see when trying to book shipments:

Shipment submit failure: Shipment booking failed. Internal service call failed. Internal Server Error: Shipment submit failure: Shipment booking failed. Internal service call failed. Internal Server Error:

Shipment submit failure: Shipment booking failed. Internal service call failed. Bad Request: An internal server error occurred, JSON Error - Carrier response could not be parsed properly: b'503 Service Temporarily Unavailable

503 Service Temporarily Unavailable


nginx'Shipment submit failure: Shipment booking failed. Internal service call failed. Bad Request: An internal server error occurred, JSON Error - Carr

Exception sending HTTP request: HTTP status code 504. Error description:
504 Gateway Time-out

504 Gateway Time-out





The issue is located on the carrier's side. We are in contact with the carrier to solve this as soon as possible and will comment here when the issue is solved. Rebooking later seems to work for now, as the errors don't appear consistently.

If you want to keep yourself updated about this incident, please subscribe to this post.
Posted Feb 21, 2024 - 16:08 CET
This incident affected: Carrier connections (DPD).