Timestamp of deployment of new code was too close to the patching time-window of our servers which caused Errors. In future extra time will be taken so these 2 different actions will not interfere again.
Posted Jan 15, 2024 - 14:50 CET
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 12:31 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2024 - 09:46 CET
Investigating
Since this morning 8:33h we're seeing a generic booking error trigger intermittently. This is the error you can see when trying to book shipments:
Transformer 2 component was not correctly initialised: config=TransformerConfigImpl [id=5120, nameId=554, routerId=2258, name=upa-booking, version=1.2.5, status=PROD, type=POOLED, createOutput=true, returnInput=false, debug=true, caching=false, className=com.transsmart.mappings.upa.booking.EntryPoint, method=..., intermediate=false, uploadDate=Thu Jan 11 08:27:43 CET 2024, arguments=[TransformerArgumentImpl [id=16090, type=java.lang.String, value=null, details=tbox_operational, paramKey=ts.dbname, paramValu
The issue is located on our side. We are attempting to solve this as soon as possible and will comment here when the issue is solved.
If you want to keep yourself updated about this incident, please subscribe to this post.
Posted Jan 11, 2024 - 09:18 CET
This incident affected: REST API and SOAP webservice.